fbpx

Reto n° 9 Fórmula Excel para sumar los dígitos de un número

reto excel formula para sumar digitos de numeros

Fórmula Excel para sumar los dígitos de un número

Reto n° 9 Fórmula Excel para sumar los dígitos de un número: vamos a poner a prueba cuanto conoces de Excel mediante un ejercicio práctico el cual puede tener varias soluciones, sin embargo la que utilice menos recursos será la mas eficiente, lo cual indicará un gran dominio de Excel. El reto Excel que te propongo a continuación es sencillo de explicar, solo debes encontrar las fórmula (varias funciones, mediante una sola función no habría forma de desarrollarlo) que sea capaz de encontrar la sumatoria de todos los dígitos que conforman un número. Debemos tener en cuenta que el número podría tener n dígitos por lo cual, la fórmula debe ser totalmente dinámica y ajustarse a todos los casos posibles.

Particularmente no he trabajado con funciones matriciales para dar respuesta a este reto Excel , sin embargo; si dominas este tipo de funciones también es válido como solución e incluso hablariamos de un dominio mas avanzado de Excel.

A continuación una explicación con una imagen animada de la solución del reto Excel.

funcion excel sumar digitos de numero

A tener en cuenta:

  1. No utilizar macros.
  2. No separar los números en dígitos.
  3. Pueden usar funciones matriciales.
  4. No consultar internet, la idea es medir tus conocimientos.

Descargar RETO

Si desarrollaste el reto de forma correcta, deja un comentario con la fórmula utilizada o envíanos el archivo a [email protected]

Descargar Función Excel para sumar dígitos de un número.xls

Solución al RETO

Descargar Solución reto – sumar dígitos de un número.xls

La fórmula que da solución al reto y que yo utilicé es la siguiente:

=SUMAPRODUCTO(1*EXTRAE(B8,FILA(INDIRECTO(«1:» & LARGO(B8))),1))

Aquí otras alternativas, si las fórmulas no funcionan cambien el separador de argumento a «;».

  • Roberto Daniel Garcia: =SI(ESNUMERO($B$8),SUMAPRODUCTO(EXTRAE($B$8,FILA(INDIRECTO(«1:»&LARGO($B$8))),1)*1),»ERROR»)
  • =SUMAPRODUCTO(EXTRAE($B$8,FILA(INDIRECTO(«1:»&LARGO($B$8))),1)*1)
  • Oscar Mendez-Roca: =SUMAPRODUCTO(–EXTRAE($B$8,SI(LARGO($B$8)>0,SI(LARGO($B$8)=1,{1},SI(LARGO($B$8)=2,{1,2},SI(LARGO($B$8)=3,{1,2,3},SI(LARGO($B$8)=4,{1,2,3,4},SI(LARGO($B$8)=5,{1,2,3,4,5},SI(LARGO($B$8)=6,{1,2,3,4,5,6},SI(LARGO($B$8)=7,{1,2,3,4,5,6,7},SI(LARGO($B$8)=8,{1,2,3,4,5,6,7,8},SI(LARGO($B$8)=9,{1,2,3,4,5,6,7,8,9},SI(LARGO($B$8)=10,{1,2,3,4,5,6,7,8,9,10},»»))))))))))),1))
  • Carlos Alb: =SUMAPRODUCTO(1*EXTRAE(B8,FILA(INDIRECTO(«1:» & LARGO(B8))),1))
  • Ezequiel Rivera: {=SUMA(EXTRAE(B8,FILA(INDIRECTO(«1:»&LARGO(B8))),1)*1)}

Estaremos colocando todas las posibles soluciones en cuanto tengamos respuesta de los usarios.

SUSCRÍBETE GRATIS

Te convertiré en un experto en Excel, tengo la experiencia y todo el material que necesitas, mi ayuda es totalmente gratuita.

Suscríbete

Agrega tu comentario

Comentarios
  1. Posted by Roberto Daniel García
    • Posted by Gustavo A. Sebastiani Cépeda
  2. Posted by Sebasitian
  3. Posted by Julio Barbieri Andrade
  4. Posted by Percy
  5. Posted by EDINSON